summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZolnai Tamás <tamas.zolnai@collabora.com>2014-06-11 12:36:26 +0200
committerZolnai Tamás <tamas.zolnai@collabora.com>2014-06-12 21:43:35 +0200
commitfe70101856332663f600df144b39d2638b3d0570 (patch)
treedb4a1ba9353118269eec8738d6c3571bbb1c6d13 /configure.ac
parent3d3fc58a32211cf56c5238f2d9f0e86a1eb7ae7e (diff)
Introduce HAVE_FEATURE_GLTF to enable/disable gltf related code
When it is a release build then enable it only on Windows and Linux. Change-Id: I7c462aeb75e6ab60eeaa0fa42ca7853a6369b742
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 298aa3c5f4ae..5c78dff5ee72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10512,12 +10512,18 @@ AC_SUBST(ENABLE_OPENCL)
dnl ===================================================================
dnl Check whether to enable glTF support
dnl ===================================================================
+AC_MSG_CHECKING([whether to enable glTF support])
+if test "$ENABLE_RELEASE_BUILD" = "TRUE"; then
+ if test $_os == iOS -o $_os == Android -o $_os = Darwin; then
+ enable_gltf=no
+ fi
+fi
ENABLE_GLTF=
-AC_MSG_CHECKING([whether to enable glTF support])
if test "x$enable_gltf" != "xno"; then
ENABLE_GLTF=TRUE
AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_FEATURE_GLTF,1)
BUILD_TYPE="$BUILD_TYPE LIBGLTF"
if test "$test_freetype" = "no"; then
BUILD_TYPE="$BUILD_TYPE FREETYPE"