summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArkadiusz Miƛkiewicz <arekm@maven.pl>2014-10-09 23:40:29 +0200
committerSamuel Mehrbrodt <s.mehrbrodt@gmail.com>2014-10-09 21:44:33 +0000
commitd5b0697cebd7d66ee90d12f7b893c193ae36eaa6 (patch)
tree87a0232254a7439c8938d9b7f80fc5fd05ad7d39 /configure.ac
parentc5cb66b537327247ebaf303951d718583de63710 (diff)
Avoid bashizm in AbsolutePath() function
&> is another bashizm. Avoid that since configure is run using POSIX shell. Some POSIX compatible shells like mksh do not understand bash syntax. "cd - &> /dev/null" was causing "cd -" command to go into background which means we never changed back to original directory thus fooling configure script later: config.status: error: cannot find input file: `config_host.mk.in' "&>" was also redirecting stderr which we don't want to do anymore since it hides real and interesting errors. Change-Id: I286a32e6a200afca883b159d9196f606e0fe7063 Reviewed-on: https://gerrit.libreoffice.org/11896 Reviewed-by: Samuel Mehrbrodt <s.mehrbrodt@gmail.com> Tested-by: Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5e61439734f..03f58b9bbee8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,7 +78,7 @@ AbsolutePath()
if test -d "$rel" ; then
cd "$rel" || AC_MSG_ERROR([absolute path resolution failed for "$rel".])
absolute_path="$(pwd)"
- cd - &> /dev/null
+ cd - > /dev/null
else
AC_MSG_ERROR([Failed to resolve absolute path. "$rel" does not exist or is not a directory.])
fi