summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrbuj <robert.buj@gmail.com>2014-06-27 02:37:54 +0200
committerNorbert Thiebaud <nthiebaud@gmail.com>2014-06-29 17:37:37 +0000
commit67c20d42b5ca06458b154356877f4ad5952736f4 (patch)
tree6d474d3744021ca28f14e59c9bb5382d9489105d /configure.ac
parent2c2df7185cd01c6cc1ed6f7acb46f0110c6b331c (diff)
OS X: PYTHON_CFLAGS & PYTHON_LIBS (--enable-python=system)
Use $FRAMEWORKSHOME instead of /Developer/SDKs/MacOSX${with_macosx_sdk}.sdk/System/Library/Frameworks. As of Xcode 5.0, Python has been moved outside the SDK, so it doesn't provide the Python framework. Now we have to use common unix parameters unlike older versions of Xcode. It is described in the technical note TN2328. Change-Id: Ib2a010e7c3839a8906acb2453c90ef2bd2f258d7 Reviewed-on: https://gerrit.libreoffice.org/9926 Reviewed-by: Norbert Thiebaud <nthiebaud@gmail.com> Tested-by: Norbert Thiebaud <nthiebaud@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f05ed540b865..c20101d3675e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8076,8 +8076,13 @@ if test $enable_python = system; then
python_version=2.7;;
esac
PYTHON=python$python_version
- PYTHON_CFLAGS="-I/Developer/SDKs/MacOSX${with_macosx_sdk}.sdk/System/Library/Frameworks/Python.framework/Versions/${python_version}/include/python${python_version}"
- PYTHON_LIBS="-framework Python"
+ if test -d "$FRAMEWORKSHOME/Python.framework/Versions/${python_version}/include/python${python_version}"; then
+ PYTHON_CFLAGS="-I$FRAMEWORKSHOME/Python.framework/Versions/${python_version}/include/python${python_version}"
+ PYTHON_LIBS="-framework Python"
+ else
+ PYTHON_CFLAGS="`$PYTHON-config --includes`"
+ PYTHON_LIBS="`$PYTHON-config --libs`"
+ fi
fi
if test -n "$PYTHON_CFLAGS" -a -n "$PYTHON_LIBS"; then
# Fallback: Accept these in the environment, or as set above