summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@rene-engelhard.de>2013-06-01 19:13:00 +0200
committerRene Engelhard <rene@rene-engelhard.de>2013-06-01 19:18:42 +0200
commit9d8ee40688902c70112d8ea9d716d10897118682 (patch)
tree0bb779147b5e0e2f640c44a679a32cf186c9af86 /configure.ac
parent1cf6f36306eb4d11279118c547e87a2c4b2551d4 (diff)
fix build with system-harfbuzz >= 0.9.18
.. as it split out the icu libs and thus we need to use harfbuzz-icu for pkg-config to get the needed -lharfbuzz-icu Change-Id: Ia4e1774ecdddec87876adf5bc5a93bed86c25046
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index af3100c0495b..d018068e4c55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8385,7 +8385,13 @@ AC_MSG_CHECKING([whether to enable HarfBuzz support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin"; then
AC_MSG_RESULT([yes])
ENABLE_HARFBUZZ="TRUE"
- libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ if test "$with_system_harfbuzz" = "yes"; then
+ if pkg-config --atleast-version 0.9.18 harfbuzz; then
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 0.9.18])
+ fi
+ else
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+ fi
else
AC_MSG_RESULT([no])
fi