summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Foley <pefoley2@verizon.net>2013-04-10 19:02:44 -0400
committerPeter Foley <pefoley2@verizon.net>2013-04-11 19:00:12 -0400
commit0e5f2ea0de71439fe121da47deaba68585541808 (patch)
treef44a0d2e0a1f3a9e8e5cae3f8e2f916c546ed7fd /configure.ac
parent6524435017f38759476970447007364e762134d0 (diff)
create --enable-mergelibs=all option
Support cramming everything into one big merged library as well as only the libraries depended upon by almost everything. Change-Id: I69647037dc62840294ba670d5d6c172a4608bf3f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 512db8012811..96ddaf761b54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -709,9 +709,10 @@ AC_ARG_ENABLE([hardlink-deliver],
)
AC_ARG_ENABLE(mergelibs,
- AS_HELP_STRING([--enable-mergelibs],
+ AS_HELP_STRING([--enable-mergelibs=<all/yes>],
[Enables linking of big, merged, library. Experimental feature tested
- only on Linux and Android.])
+ only on Linux and Android. All will link a lot more libraries into libmerged
+ while yes or no argument will simply enable a core set of libraries.])
)
AC_ARG_ENABLE(graphite,
@@ -11632,16 +11633,21 @@ fi
# ===================================================================
AC_MSG_CHECKING([whether to create huge library])
MERGELIBS=
-if test "$enable_mergelibs" = "yes"; then
+if test "$enable_mergelibs" != "no"; then
if test $_os != Linux -a $_os != Android -a $_os != WINNT; then
add_warning "--enable-mergelibs is not tested for this platform"
fi
- MERGELIBS="TRUE"
+ if test "$enable_mergelibs" = "all"; then
+ MERGELIBS="ALL"
+ URELIBS="TRUE"
+ else
+ MERGELIBS="CORE"
+ fi
AC_MSG_RESULT([yes])
else
AC_MSG_RESULT([no])
fi
-AC_SUBST(MERGELIBS)
+AC_SUBST([MERGELIBS])
AC_SUBST([URELIBS])
# ===================================================================