summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCédric Bosdonnat <cedric.bosdonnat@free.fr>2013-11-19 08:55:24 +0100
committerCédric Bosdonnat <cedric.bosdonnat@free.fr>2013-11-19 14:52:39 +0100
commit7586bea9fb4c51e7221e403fa965067c8e1cd4a2 (patch)
tree0fedfa95695ae307dc9272c9a9664d2b887498c9 /configure.ac
parent87bd65efacdd668d304e88dcac9d2d119666ef1f (diff)
Add data for Alfresco Cloud CMIS connection
Change-Id: Ie5374f2e81e1429294805f05ae432fba86cc50df
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac48
1 files changed, 44 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b75be239292f..17aecb5943f9 100755
--- a/configure.ac
+++ b/configure.ac
@@ -2032,19 +2032,33 @@ AC_ARG_WITH(all-tarballs,
[Download all external tarballs unconditionally]))
AC_ARG_WITH(gdrive-client-id,
- AS_HELP_STRING([--with-drive-client-id],
+ AS_HELP_STRING([--with-gdrive-client-id],
[Provides the client id of the application for OAuth2 authentication
on Google Drive. If either this or --with-gdrive-client-secret is
empty, the feature will be disabled]),
)
AC_ARG_WITH(gdrive-client-secret,
- AS_HELP_STRING([--with-drive-client-secret],
+ AS_HELP_STRING([--with-gdrive-client-secret],
[Provides the client secret of the application for OAuth2
authentication on Google Drive. If either this or
--with-gdrive-client-id is empty, the feature will be disabled]),
)
+AC_ARG_WITH(alfresco-cloud-client-id,
+ AS_HELP_STRING([--with-alfresco-cloud-client-id],
+ [Provides the client id of the application for OAuth2 authentication
+ on Alfresco Cloud. If either this or --with-alfresco-cloud-client-secret is
+ empty, the feature will be disabled]),
+)
+
+AC_ARG_WITH(alfresco-cloud-client-secret,
+ AS_HELP_STRING([--with-alfresco-cloud-client-secret],
+ [Provides the client secret of the application for OAuth2
+ authentication on Alfresco Cloud. If either this or
+ --with-alfresco-cloud-client-id is empty, the feature will be disabled]),
+)
+
dnl ===================================================================
dnl Do we want to use pre-build binary tarball for recompile
dnl ===================================================================
@@ -12314,16 +12328,42 @@ AC_SUBST(TESTINSTALLDIR)
AC_MSG_CHECKING([for Google Drive client id and secret])
GDRIVE_CLIENT_ID="\"$with_gdrive_client_id\""
GDRIVE_CLIENT_SECRET="\"$with_gdrive_client_secret\""
-if test "$with_gdrive_client_id" = "no" -o -n "$with_driver_client_id"; then
+if test "$with_gdrive_client_id" = "no" -o -z "$with_gdrive_client_id"; then
GDRIVE_CLIENT_ID="\"\""
fi
-if test "$with_gdrive_client_secret" = "no" -o -n "$with_driver_client_secret"; then
+if test "$with_gdrive_client_secret" = "no" -o -z "$with_gdrive_client_secret"; then
GDRIVE_CLIENT_SECRET="\"\""
fi
+
+if test -z "$GDRIVE_CLIENT_ID" -o -z "$GDRIVE_CLIENT_SECRET"; then
+ AC_MSG_RESULT([not set])
+else
+ AC_MSG_RESULT([set])
+fi
+
AC_DEFINE_UNQUOTED(GDRIVE_CLIENT_ID, $GDRIVE_CLIENT_ID)
AC_DEFINE_UNQUOTED(GDRIVE_CLIENT_SECRET, $GDRIVE_CLIENT_SECRET)
+AC_MSG_CHECKING([for Alfresco Cloud client id and secret])
+ALFRESCO_CLOUD_CLIENT_ID="\"$with_alfresco_cloud_client_id\""
+ALFRESCO_CLOUD_CLIENT_SECRET="\"$with_alfresco_cloud_client_secret\""
+if test "$with_alfresco_cloud_client_id" = "no" -o -z "$with_alfresco_cloud_client_id"; then
+ ALFRESCO_CLOUD_CLIENT_ID="\"\""
+fi
+
+if test "$with_alfresco_cloud_client_secret" = "no" -o -z "$with_alfresco_cloud_client_secret"; then
+ ALFRESCO_CLOUD_CLIENT_SECRET="\"\""
+fi
+
+if test -z "$ALFRESCO_CLOUD_CLIENT_ID" -o -z "$ALFRESCO_CLOUD_CLIENT_SECRET"; then
+ AC_MSG_RESULT([not set])
+else
+ AC_MSG_RESULT([set])
+fi
+AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_ID, $ALFRESCO_CLOUD_CLIENT_ID)
+AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_SECRET, $ALFRESCO_CLOUD_CLIENT_SECRET)
+
# ===================================================================
# De- or increase default verbosity of build process
# ===================================================================