summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMihai Varga <mihai.mv13@gmail.com>2014-06-23 19:14:08 +0300
committerMiklos Vajna <vmiklos@collabora.co.uk>2014-12-15 11:23:24 +0100
commitfc1bfd9e6d774917bd90d67b1135402d2d33ef6b (patch)
tree232d72d467ca8a2b5569467061225ff51351f52a /configure.ac
parenta7b86c0e647bef6da677fa71aa921976bd165138 (diff)
OneDrive binding settings
Change-Id: I72c97931098c1a029d39532e3433c0aeaba73e3f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 72ef58c523e0..c1adcfaf4834 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2225,6 +2225,19 @@ AC_ARG_WITH(alfresco-cloud-client-secret,
--with-alfresco-cloud-client-id is empty, the feature will be disabled]),
)
+AC_ARG_WITH(onedrive-client-id,
+ AS_HELP_STRING([--with-onedrive-client-id],
+ [Provides the client id of the application for OAuth2 authentication
+ on OneDrive. If either this or --with-onedrive-client-secret is
+ empty, the feature will be disabled]),
+)
+
+AC_ARG_WITH(onedrive-client-secret,
+ AS_HELP_STRING([--with-onedrive-client-secret],
+ [Provides the client secret of the application for OAuth2
+ authentication on OneDrive. If either this or
+ --with-onedrive-client-id is empty, the feature will be disabled]),
+)
dnl ===================================================================
dnl Do we want to use pre-build binary tarball for recompile
dnl ===================================================================
@@ -12361,6 +12374,26 @@ fi
AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_ID, $ALFRESCO_CLOUD_CLIENT_ID)
AC_DEFINE_UNQUOTED(ALFRESCO_CLOUD_CLIENT_SECRET, $ALFRESCO_CLOUD_CLIENT_SECRET)
+AC_MSG_CHECKING([for OneDrive client id and secret])
+ONEDRIVE_CLIENT_ID="\"$with_onedrive_client_id\""
+ONEDRIVE_CLIENT_SECRET="\"$with_onedrive_client_secret\""
+if test "$with_onedrive_client_id" = "no" -o -z "$with_onedrive_client_id"; then
+ ONEDRIVE_CLIENT_ID="\"\""
+fi
+
+if test "$with_onedrive_client_secret" = "no" -o -z "$with_onedrive_client_secret"; then
+ ONEDRIVE_CLIENT_SECRET="\"\""
+fi
+
+if test -z "$ONEDRIVE_CLIENT_ID" -o -z "$ONEDRIVE_CLIENT_SECRET"; then
+ AC_MSG_RESULT([not set])
+else
+ AC_MSG_RESULT([set])
+fi
+AC_DEFINE_UNQUOTED(ONEDRIVE_CLIENT_ID, $ONEDRIVE_CLIENT_ID)
+AC_DEFINE_UNQUOTED(ONEDRIVE_CLIENT_SECRET, $ONEDRIVE_CLIENT_SECRET)
+
+
# ===================================================================
# De- or increase default verbosity of build process
# ===================================================================