summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2017-08-22 22:26:43 +0200
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2019-08-30 23:32:05 +0200
commita9a77cca16817c4c0e181fda9f87935aea1c805d (patch)
tree03304b755c9e90ce58644e479c1bf959dfab995e /configure.ac
parent7f310986e1482a0fd49cf673316b31bde8f8e348 (diff)
configure: try to keep PYTHON_VERSION from going stale
Since it was set to 3.5.0, the bundled python was upgraded twice, but the directory is still named python-core-3.5.0 :( Reviewed-on: https://gerrit.libreoffice.org/41433 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com> (cherry picked from commit ac3a4fe35e873de17eefb46c3f5e792aded6b0a5) Reviewed-on: https://gerrit.libreoffice.org/56683 Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Change-Id: I15eec4148c2436e1f289d9851ce5bd212d4a368a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82662b4bd564..ba5aecfc9d14 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8404,6 +8404,9 @@ internal)
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=5
PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.5
+ if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
+ AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])
+ fi
AC_DEFINE_UNQUOTED([PYTHON_VERSION_STRING], [L"${PYTHON_VERSION}"])
BUILD_TYPE="$BUILD_TYPE PYTHON"
# Embedded Python dies without Home set