summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2014-08-07 15:25:15 +0200
committerStephan Bergmann <sbergman@redhat.com>2014-08-07 15:26:53 +0200
commit7479729487e167c61c69b77f5e270e639160005b (patch)
tree8965e33ff18162a50ba6b7eeead09f2edfe9021d /configure.ac
parentb4589038b35f684d270f2beb43fad579f2e4b25b (diff)
Work around dirty Qt4 test code
...failing under -fsanitize=undefined -fno-sanitize-recover Change-Id: I33a72bc1474708847f4cfc6d3d2ae6a19eb80c7f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8706f17ddabc..12e5f817ff55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11498,6 +11498,13 @@ int main(int argc, char **argv) {
qt4_fix_warning=
AC_LANG_PUSH([C++])
+ # tst_exclude_socket_notifiers.moc:70:28: runtime error: member access within address 0x60d00000bb20 which does not point to an object of type 'QObjectData'
+ # 0x60d00000bb20: note: object is of type 'QObjectPrivate'
+ # 02 00 80 3a 90 8a 4e d2 3a 00 00 00 f0 b4 b9 a7 ff 7f 00 00 00 00 00 00 00 00 00 00 20 d8 4e d2
+ # ^~~~~~~~~~~~~~~~~~~~~~~
+ # vptr for 'QObjectPrivate'
+ save_CXX=$CXX
+ CXX=$(printf %s "$CXX" | sed -e s/-fno-sanitize-recover//)
save_CXXFLAGS=$CXXFLAGS
CXXFLAGS="$CXXFLAGS $KDE4_CFLAGS"
save_LIBS=$LIBS
@@ -11574,6 +11581,7 @@ int main(int argc, char *argv[])
LIBS=$save_LIBS
CXXFLAGS=$save_CXXFLAGS
+ CXX=$save_CXX
AC_LANG_POP([C++])
],
AC_MSG_WARN([[No Glib found, KDE4 support will not use native file pickers!]]))