summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2017-11-17 04:37:29 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2017-11-20 22:32:22 +0100
commitdaee5fc5569c1807f5c8dae502d305eb06141e8b (patch)
tree7cee92092d2509cb6bdcea923d11f060a7ce334f /configure.ac
parent5fccf17f33aa7e97314c14a5a4616b2f2643614c (diff)
gpg4libre: add glib2 dependency for Windows
Change-Id: Ib6b5393323a4dbfe94ea89689ac9170f8afa3899 Reviewed-on: https://gerrit.libreoffice.org/44856 Reviewed-by: Siegmund Gorr <siegmund.gorr@cib.de> Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92cbf7eedc6d..0d2b8aca01a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10151,8 +10151,11 @@ if test "$_os" = "Linux" -o "$_os" = "Darwin"; then
[AC_MSG_ERROR([gpgme headers not found, install gpgme development package])], [])
else
AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGMEPP"
AC_DEFINE([GPGME_CAN_EXPORT_MINIMAL_KEY])
+ BUILD_TYPE="$BUILD_TYPE LIBGPGERROR LIBASSUAN GPGMEPP"
+ if test "$_os" = "WINNT"; then
+ BUILD_TYPE="$BUILD_TYPE GLIB2"
+ fi
GPG_ERROR_CFLAGS="-I${WORKDIR}/UnpackedTarball/libgpg-error/src"
GPG_ERROR_LIBS="-L${WORKDIR}/UnpackedTarball/libgpg-error/src/.libs -lgpg-error"