summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-10-05 12:26:25 +0200
committerjan Iversen <jani@libreoffice.org>2017-10-05 12:30:30 +0200
commitaa000a137ff8775aa370d6e0330d3d34323c5433 (patch)
tree517cbee683d6fee9a6ea6f359041b921e10fb00c /configure.ac
parentee46269003aed237edcd9c086fd14ecded08bbeb (diff)
iOS, do not cross-compile for simulator
When compiling for the simulator, we should not cross compile, since it is only using another sdk. setting cross-compile when the architecture is the same causes problems with several third party libs. The unsolved problem is how to build cmdline tools. Change-Id: Ida0b31bb12f6eadca413eb6e1874553adb8be6cd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3e197436cdcb..057c5ef2db26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3075,7 +3075,7 @@ if test "$_os" = "WINNT"; then
BITNESS_OVERRIDE=64
fi
fi
-if test "$_os" = "iOS"; then
+if test "$_os" = "iOS" -a "$host_cpu" = "arm64"; then
cross_compiling="yes"
fi