summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-11-02 18:09:14 +0100
committerjan Iversen <jani@libreoffice.org>2017-11-02 18:16:43 +0100
commit7178336b59060f9846f5e15ef95b923d0be1c8df (patch)
treefb0905b4791c19e0cf36e479d69708ca91c485b3 /configure.ac
parentd01f0d53ca5eefb81f10a6f52b1531e8bb781069 (diff)
iOS, remove bitcode from compiler
compiling with bitcode slows builds process Change-Id: Icee263652d31f3a7a6e92a91ef5320a804d0bef1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2744367421c4..2537a1689b69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2837,11 +2837,9 @@ if test $_os = iOS; then
if test "$enable_ios_simulator" = "yes"; then
platform=iPhoneSimulator
versionmin=-mios-simulator-version-min=10.3
- BITNESS=-fembed-bitcode
else
platform=iPhoneOS
versionmin=-miphoneos-version-min=10.3
- BITNESS=-fembed-bitcode
fi
xcode_developer=`xcode-select -print-path`
@@ -2874,8 +2872,8 @@ if test $_os = iOS; then
stdlib="-stdlib=libc++"
- CC="`xcrun -find clang` -arch $host_cpu -fvisibility=hidden $BITNESS -isysroot $sysroot $lto $versionmin"
- CXX="`xcrun -find clang++` -arch $host_cpu -fvisibility=hidden $stdlib $BITNESS -isysroot $sysroot $lto $versionmin"
+ CC="`xcrun -find clang` -arch $host_cpu -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
+ CXX="`xcrun -find clang++` -arch $host_cpu -fvisibility=hidden $stdlib -isysroot $sysroot $lto $versionmin"
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`