summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2017-10-18 07:53:21 +0300
committerEike Rathke <erack@redhat.com>2017-10-19 21:55:09 +0200
commit334a9f16cd1d1f9694f885c759903a41aa3d4833 (patch)
tree4a40e181386131b6a535adecc2649cd61060ac3a /configure.ac
parent2c41e9924120ec2e399de9b4d8248f25712ae400 (diff)
tdf#113211: fix calculations with big integers
... and munbers with few fractional bits Change-Id: I86c3e8021e803fed498fae768ded9c9e5337c8bd Reviewed-on: https://gerrit.libreoffice.org/43477 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Eike Rathke <erack@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac8dbc52463d..a330547d2b21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5795,6 +5795,15 @@ if test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
AC_MSG_RESULT([no])
fi
+ AC_MSG_CHECKING([whether $CC supports __builtin_ffs])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return __builtin_ffs(1); ]])],[HAVE_GCC_BUILTIN_FFS=TRUE],[])
+ if test "$HAVE_GCC_BUILTIN_FFS" = "TRUE"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_GCC_BUILTIN_FFS)
+ else
+ AC_MSG_RESULT([no])
+ fi
+
AC_MSG_CHECKING([whether $CC supports __attribute__((deprecated(message)))])
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror"
@@ -5943,6 +5952,7 @@ fi
AC_SUBST(HAVE_GCC_AVX)
AC_SUBST(HAVE_GCC_STACK_PROTECTOR_STRONG)
AC_SUBST(HAVE_GCC_BUILTIN_ATOMIC)
+AC_SUBST(HAVE_GCC_BUILTIN_FFS)
dnl ===================================================================
dnl Identify the C++ library