summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-09-30 16:14:17 +0200
committerjan Iversen <jani@libreoffice.org>2017-09-30 16:15:36 +0200
commit0e3eb2c1eb75655ea61a1bf0716dab0acaf19467 (patch)
treeb16bceb1be163a9538cc34359800157f58fc7127 /configure.ac
parent2e8a95d1f87a3dbdcc8846fa44d1899abc8edd9c (diff)
iOS, cleanup unused config variables
Removed no longer used variables. These variables are constant across platform, and therefore defined in the project.pbxproj file instead. Change-Id: I8fcfe414de498ebd4e5bd3a133a8c7e39faa9edb
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 6 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 0b184164e43a..204241efc67b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2872,12 +2872,12 @@ if test $_os = iOS; then
if test "$enable_ios_simulator" = "yes"; then
platform=iPhoneSimulator
versionmin=-mios-simulator-version-min=9.3
- IOS_ARCHS=x86_64
+ IOS_ARCH=x86_64
BITNESS=-fembed-bitcode
else
platform=iPhoneOS
versionmin=-miphoneos-version-min=9.3
- IOS_ARCHS=arm64
+ IOS_ARCH=arm64
BITNESS=-fembed-bitcode
fi
xcode_developer=`xcode-select -print-path`
@@ -2909,11 +2909,10 @@ if test $_os = iOS; then
# get compiled with it, to avoid ld warnings when linking all that together into one
# executable.
- IOS_CLANG_CXX_LIBRARY=libc++
- stdlib="-stdlib=$IOS_CLANG_CXX_LIBRARY"
+ stdlib="-stdlib=libc++"
- CC="`xcrun -find clang` -arch $IOS_ARCHS -fvisibility=hidden $BITNESS -isysroot $sysroot $lto $versionmin"
- CXX="`xcrun -find clang++` -arch $IOS_ARCHS -fvisibility=hidden $stdlib $BITNESS -isysroot $sysroot $lto $versionmin"
+ CC="`xcrun -find clang` -arch $IOS_ARCH -fvisibility=hidden $BITNESS -isysroot $sysroot $lto $versionmin"
+ CXX="`xcrun -find clang++` -arch $IOS_ARCH -fvisibility=hidden $stdlib $BITNESS -isysroot $sysroot $lto $versionmin"
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`
@@ -2923,8 +2922,7 @@ if test $_os = iOS; then
RANLIB=`xcrun -find ranlib`
fi
-AC_SUBST(IOS_CLANG_CXX_LIBRARY)
-AC_SUBST(IOS_ARCHS)
+AC_SUBST(IOS_ARCH)
AC_SUBST(IOS_SDK)
AC_MSG_CHECKING([whether to treat the installation as read-only])
@@ -3868,15 +3866,6 @@ if test -n "$with_android_ndk" -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG"
fi
fi
-# Debug information format for iOS. Running dsymutil takes a long time... you really need a separate
-# .dSYM only if running Instruments, I think. (Not for normal debugging in Xcode.) To enable a
-# separate .dSYM, either use --enable-release-build or change manually to "DWARF with DSYM" in Xcode.
-IOS_DEBUG_INFORMATION_FORMAT=dwarf-with-dsym
-if test "$enable_release_build" != yes -a \( -n "$ENABLE_SYMBOLS" -o -n "$ENABLE_DEBUG" -o -n "$ENABLE_DBGUTIL" \); then
- IOS_DEBUG_INFORMATION_FORMAT=dwarf
-fi
-AC_SUBST(IOS_DEBUG_INFORMATION_FORMAT)
-
AC_MSG_CHECKING([whether to compile with optimization flags])
if test -z "$enable_optimized"; then
if test -n "$ENABLE_DEBUG$ENABLE_DBGUTIL"; then