summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-10-06 14:50:22 +0200
committerjan Iversen <jani@libreoffice.org>2017-10-06 14:55:37 +0200
commit02ab7371e10172bdf3474551f3912a148cdf66e2 (patch)
tree5a914a94d6b6f2f4293115cfa1294b8ef3c3fcda /configure.ac
parentee75810ecb8f656c87363b8b952033c8ddb61de7 (diff)
iOS cross-compile even for x86-64
Based on advice from IRC, cross compile is also active for simulator. The assumption build arch == host arch calls for not cross compiling, did not work due to the fact that iOS compiles without DESKTOP. Cross compiling to the same platform gives problems with e.g. libxml2 will be solved in a later commit Change-Id: If18ee5f9473dd983e2cb705390017229c4205a71
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 396d02b88296..f02204df4b81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3075,7 +3075,7 @@ if test "$_os" = "WINNT"; then
BITNESS_OVERRIDE=64
fi
fi
-if test "$_os" = "iOS" -a "$host_cpu" = "arm64"; then
+if test "$_os" = "iOS"; then
cross_compiling="yes"
fi