summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2017-12-07 13:45:31 +0100
committerJan Holesovsky <kendy@collabora.com>2018-08-08 14:47:28 +0200
commit4d5bcb8f387829dc47efea4e9042e57020fee8a9 (patch)
tree384d41a3d9dae748461f7d1b2a06abf811523542 /configure.ac
parentbc394374b28238747f09e18fb97214ee69db6976 (diff)
allow to build online help too
Change-Id: I9b26f952dc681893b25712451535f4b539fd615d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6a1bdc039da9..99443fa0106c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1879,6 +1879,7 @@ AC_ARG_WITH(help,
Usage: --with-help build the old local help
--without-help no local help (default)
--with-help=html build the new HTML local help
+ --with-help=online build the new HTML online help
--with-help=common bundle common files for the local
help but do not build the whole help
],
@@ -4617,6 +4618,11 @@ if test -n "$with_help" -a "$with_help" != "no" -a $_os != iOS -a $_os != Androi
ENABLE_HTMLHELP=TRUE
AC_MSG_RESULT([HTML])
;;
+ "online")
+ ENABLE_HTMLHELP=TRUE
+ HELP_ONLINE=TRUE
+ AC_MSG_RESULT([HTML])
+ ;;
*)
SCPDEFS="$SCPDEFS -DWITH_HELP"
AC_MSG_RESULT([yes])
@@ -4627,6 +4633,7 @@ else
fi
AC_SUBST([ENABLE_HTMLHELP])
AC_SUBST(HELP_COMMON_ONLY)
+AC_SUBST([HELP_ONLINE])
dnl Test whether to include MySpell dictionaries
dnl ===================================================================