summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2021-06-09 13:41:30 +0100
committerCaolán McNamara <caolanm@redhat.com>2021-06-09 17:07:56 +0200
commit33b4198735af8d9398e63887187b86b4176cac82 (patch)
treeed8444bf8acbb00e0209fc74ca0b09219ecedccd /configure.ac
parentacf565ea13204479f215ca597a432d69dac4290d (diff)
allow system firebird 4
Change-Id: I330065f61d2d0fdfeeaeba4ee2e739e222d1c665 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116918 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 077684be36b4..e860d4a5f199 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10103,11 +10103,10 @@ if test "$enable_firebird_sdbc" = "yes" ; then
AC_MSG_CHECKING([Firebird version])
if test -n "${FIREBIRD_VERSION}"; then
FIREBIRD_MAJOR=`echo $FIREBIRD_VERSION | cut -d"." -f1`
- FIREBIRD_MINOR=`echo $FIREBIRD_VERSION | cut -d"." -f2`
- if test "$FIREBIRD_MAJOR" -eq "3" -a "$FIREBIRD_MINOR" -eq "0"; then
+ if test "$FIREBIRD_MAJOR" -ge "3"; then
AC_MSG_RESULT([OK])
else
- AC_MSG_ERROR([Ensure firebird 3.0.x is installed])
+ AC_MSG_ERROR([Ensure firebird >= 3 is installed])
fi
else
save_CFLAGS="${CFLAGS}"