summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2021-05-25 13:30:38 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2021-05-26 00:29:00 +0200
commit15ab55c092e0b474827abe104b73c5bfab6ef28c (patch)
treec9189516786794e229ac1d356eb17e0c85c4b290 /configure.ac
parent4d800dd7b58291386850d69570d027192419c5a0 (diff)
add privacy URL to crashreport dialog & updatecheck tab in options
Change-Id: I35cda87c35876469bf581be223bc608e29f07b09 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/116105 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 971d7ad440c5..4652067a64de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2576,6 +2576,17 @@ AC_ARG_WITH(vendor,
[Set vendor of the build.]),
,)
+AC_ARG_WITH(privacy-policy-url,
+ AS_HELP_STRING([--with-privacy-policy-url="https://yourdomain/privacy-policy"],
+ [The URL to your privacy policy (needed when
+ enabling online-update or crashreporting via breakpad)]),
+ [if test "x$with_privacy_policy_url" = "xyes"; then
+ AC_MSG_FAILURE([you need to specify an argument when using --with-privacy-policy-url])
+ elif test "x$with_privacy_policy_url" = "xno"; then
+ with_privacy_policy_url="undefined"
+ fi]
+,[with_privacy_policy_url="undefined"])
+
AC_ARG_WITH(android-package-name,
AS_HELP_STRING([--with-android-package-name="org.libreoffice"],
[Set Android package name of the build.]),
@@ -12946,6 +12957,14 @@ AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
AC_SUBST(UPDATE_CONFIG)
+
+PRIVACY_POLICY_URL="$with_privacy_policy_url"
+if test "$ENABLE_ONLINE_UPDATE" = TRUE -o "$ENABLE_BREAKPAD" = "TRUE"; then
+ if test "x$with_privacy_policy_url" = "xundefined"; then
+ AC_MSG_FAILURE([online update or breakpad/crashreporting are enabled, but no privacy url was provided])
+ fi
+fi
+AC_SUBST(PRIVACY_POLICY_URL)
dnl ===================================================================
dnl Test whether we need bzip2
dnl ===================================================================