summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2014-10-01 11:32:59 +0100
committerCaolán McNamara <caolanm@redhat.com>2014-10-01 11:34:14 +0100
commita6b2c618cb02168bba950652367f494a1021cf53 (patch)
treeee1dbf3abdd805502eacaef6a5f065cff82bed42 /configure.ac
parent544c4fc14bca0e670ed1d59569f22c5d4a643c72 (diff)
disable cve tests by default on windows
what we really want to do here is to disable if there is a virus checker active that will cause us grief Change-Id: Ic1162c9e1cf7a8ee09ca1dbf03b5be02dd20b981
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d58df767ae73..4c6aec95cda9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9128,6 +9128,20 @@ dnl ===================================================================
dnl Check for disabling cve_tests
dnl ===================================================================
AC_MSG_CHECKING([whether to execute CVE tests])
+# If not explicitly enabled or disabled, default
+if test -z "$enable_cve_tests"; then
+ case "$OS" in
+ WNT)
+ # Default cves off for windows with its wild and wonderful
+ # varienty of AV software kicking in and panicing
+ enable_cve_tests=no
+ ;;
+ *)
+ # otherwise yes
+ enable_cve_tests=yes
+ ;;
+ esac
+fi
if test "$enable_cve_tests" = "no"; then
AC_MSG_RESULT([no])
DISABLE_CVE_TESTS=TRUE