summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-06-06 17:39:04 +0300
committerTor Lillqvist <tml@collabora.com>2014-06-06 17:57:06 +0300
commitd65532e92e209d486cffe260adc849ae96683e6a (patch)
tree35125c60c32241efce1dd2417f5103251819d1ed /configure.ac
parent7bafca39603f7af4c364b7ec780b7b513ae9caf9 (diff)
PackageMaker does not exist any more
Change-Id: Iefd1980fc87daa709e8e5c833407c2595e71b401
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 3 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 899dc9143ffa..e1b1ea61b673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1419,7 +1419,7 @@ AC_ARG_WITH(package-format,
[Specify package format(s) for LibreOffice installation sets. The
implicit --without-package-format leads to no installation sets being
generated. Possible values: aix, archive, bsd, deb, dmg,
- installed, msi, native, osx, pkg, portable, and rpm.
+ installed, msi, native, pkg, portable, and rpm.
Example: --with-package-format='deb rpm']),
,)
@@ -4402,14 +4402,13 @@ AC_MSG_CHECKING([which package format to use])
if test -n "$with_package_format" -a "$with_package_format" != no; then
for i in $with_package_format; do
case "$i" in
- aix | bsd | deb | osx | pkg | rpm | native | portable | archive | dmg | installed | msi)
+ aix | bsd | deb | pkg | rpm | native | portable | archive | dmg | installed | msi)
;;
*)
AC_MSG_ERROR([unsupported format $i. Supported by EPM are:
aix - AIX software distribution
bsd - FreeBSD, NetBSD, or OpenBSD software distribution
deb - Debian software distribution
-osx - MacOS X software distribution
pkg - Solaris software distribution
rpm - RedHat software distribution
native - "Native" software distribution for the platform
@@ -7376,18 +7375,6 @@ if test "$enable_epm" = "yes"; then
AC_MSG_ERROR([dpkg needed for deb creation. Install dpkg.])
fi
fi
- if echo "$PKGFORMAT" | $EGREP osx 2>&1 >/dev/null; then
- if test "$_os" = "Darwin"; then
- AC_MSG_CHECKING([for PackageMaker availability])
- if ! test -x /Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker; then
- AC_MSG_ERROR([not installed. Please install Apples Dev Tools])
- else
- AC_MSG_RESULT([ok])
- fi
- else
- AC_MSG_ERROR([PackageMaker needed to build OSX packages and you are not on OSX...])
- fi
- fi
if echo "$PKGFORMAT" | $EGREP rpm 2>&1 >/dev/null || \
echo "$PKGFORMAT" | $EGREP pkg 2>&1 >/dev/null; then
if test "$with_epm" = "no" -a "$_os" != "Darwin"; then
@@ -7426,7 +7413,7 @@ if test "$enable_epm" = "yes"; then
else
for i in $PKGFORMAT; do
case "$i" in
- aix | bsd | deb | osx | pkg | rpm | native | portable)
+ aix | bsd | deb | pkg | rpm | native | portable)
AC_MSG_ERROR(
[--with-package-format='$PKGFORMAT' requires --enable-epm])
;;