summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-03-31 19:18:41 +0200
committerMatúš Kukan <matus.kukan@collabora.com>2014-04-01 20:28:21 +0200
commitb2e4161676073bf3f205e72a19f3a62abbfc23fd (patch)
tree6457abb3370aa3bba4b4804be7666b6c1e5f72aa /configure.ac
parent23e8a2a6f88c6d9e9eba631a522943dbfa1031ce (diff)
Install coinmp and lpsolve linear solvers in parallel.
(cherry picked from commit de7cdbc5840fd7d958d486901e405890eff224b9) + some amending Conflicts: Repository.mk config_host.mk.in Change-Id: If07d94a2f646c8377b76fdf645e85f9491e4f061
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 770b0738e4c7..0b09fdebe079 100644
--- a/configure.ac
+++ b/configure.ac
@@ -638,6 +638,7 @@ linux-android*)
enable_neon=no
enable_mpl_subset=yes
enable_opengl=no
+ enable_coinmp=no
enable_lpsolve=no
enable_report_builder=no
with_theme="tango"
@@ -7453,6 +7454,7 @@ if test $_os = iOS; then
enable_mpl_subset=yes
enable_opengl=no
enable_lotuswordpro=no
+ enable_coinmp=no
enable_lpsolve=no
enable_postgresql_sdbc=no
enable_lotuswordpro=no
@@ -9503,8 +9505,17 @@ dnl ===================================================================
dnl How should we build the linear programming solver ?
dnl ===================================================================
-# Should we check for system CoinMP ? How to do that ?
-BUILD_TYPE="$BUILD_TYPE COINMP"
+ENABLE_COINMP=
+AC_MSG_CHECKING([whether to build with CoinMP])
+if test "$enable_coinmp" != "no"; then
+ ENABLE_COINMP=TRUE
+ AC_MSG_RESULT([yes])
+ # Should we check for system CoinMP ? How to do that ?
+ BUILD_TYPE="$BUILD_TYPE COINMP"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_COINMP)
ENABLE_LPSOLVE=
AC_MSG_CHECKING([whether to build with lpsolve])