summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2017-01-07 16:46:14 +0100
committerRene Engelhard <rene@debian.org>2017-01-09 18:42:48 +0100
commit22779b136058934f1af0dcfa50ba23ea6220db87 (patch)
tree8fbf0817f591260b66429e4dc4875cc76d95303a /configure.ac
parenta5a94537d804f20a0d6472ef2e5995cee2d5b2fe (diff)
use (new) -mlong-jump-table-offsets on m68k for libxo
Change-Id: I6e2886e2de4f3502c74f1e367216066352994865
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e808f1424409..dce68923da52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3778,6 +3778,19 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
fi
+
+ if test "$host_cpu" = "m68k"; then
+ AC_MSG_CHECKING([whether $CC supports -mlong-jump-table-offsets])
+ save_CFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS -Werror -mlong-jump-table-offsets"
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],[ HAVE_GCC_LONG_JUMP_TABLE_OFFSETS=TRUE ],[])
+ CFLAGS=$save_CFLAGS
+ if test "$HAVE_GCC_LONG_JUMP_TABLE_OFFSETS" = "TRUE"; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_ERROR([no])
+ fi
+ fi
fi
AC_SUBST(HAVE_GCC_GGDB2)
AC_SUBST(HAVE_GCC_FINLINE_LIMIT)