summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-07-08 17:59:59 +0300
committerTor Lillqvist <tml@collabora.com>2014-07-08 18:20:48 +0300
commita1711c717e0b5b7b2b5b722aba34cf32aa6c87aa (patch)
tree5d4aca1b7e5fe6fff5b4f249bb9a1559d21ae544 /configure.ac
parent65f12c0e16638d3285539d9901e7300f3d12c615 (diff)
Construct and propagate the argument to xcodebuild's -sdk option
Change-Id: I810ea99f61c47da62f2489d5176f6fbb779134a9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12e45dd49fe1..efe0bf4aebbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3163,6 +3163,8 @@ if test $_os = iOS; then
AC_MSG_RESULT($sysroot)
+ XCODEBUILD_SDK=`echo $platform | tr A-Z a-z`$ios_sdk
+
if test "$enable_ios_simulator" = yes; then
if test "$BITNESS_OVERRIDE" = 64; then
XCODE_ARCHS=x86_64
@@ -3225,6 +3227,7 @@ fi
AC_SUBST(XCODE_CLANG_CXX_LIBRARY)
AC_SUBST(XCODE_ARCHS)
+AC_SUBST(XCODEBUILD_SDK)
AC_MSG_CHECKING([whether to treat the installation as read-only])