summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-07-23 13:55:32 +0200
committerMichael Stahl <mstahl@redhat.com>2014-07-23 13:59:57 +0200
commit663c181c5662921e8a81b16233d60a497b30ea12 (patch)
treeb81709fd42004f4169b1051cf957d71a56e45736 /configure.ac
parent6528c8732294445481f792f27aab784a4f6fddd1 (diff)
configure: stop calling native Win32 make "horribly slow"
OTOH we do have sufficient data to start name-calling Cygwin make: http://lists.freedesktop.org/archives/libreoffice/2014-June/061727.html Change-Id: I290c39805d237c7da9a7aa954ec45a58c92fa2d2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 15 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index c3373853f1df..e0e8eeff63d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5106,7 +5106,7 @@ AC_SUBST(HAVE_GNUMAKE_FILE_FUNC)
AC_SUBST(GNUMAKE)
AC_SUBST(GNUMAKE_WIN_NATIVE)
-_make_ver_check=`$GNUMAKE --version | grep LibreOffice`
+_make_ver_check=`$GNUMAKE --version | grep "Built for Windows"`
STALE_MAKE=
make_warning=
if test "$_make_ver_check" = ""; then
@@ -13087,35 +13087,31 @@ fi
if test "$STALE_MAKE" = "TRUE" -a "$build_os" = "cygwin"; then
-cygwin_arch=`echo $MACHTYPE | sed 's/-.*//'`
-if test "$cygwin_arch" = "x86_64"; then
- download_make_url=http://users.freedesktop.org/~michael/x86_64/make
-else
- download_make_url=http://dev-www.libreoffice.org/bin/cygwin/make
-fi
-
cat << _EOS
****************************************************************************
WARNING:
Your make version is known to be horribly slow, and hard to debug
problems with. To get a reasonably functional make please do:
-to install a pre-compiled binary make for cygwin
+to install a pre-compiled binary make for Win32
-mkdir -p /opt/lo/bin
-cd /opt/lo/bin
-wget $download_make_url
-chmod +x make
+ mkdir -p /opt/lo/bin
+ cd /opt/lo/bin
+ wget http://dev-www.libreoffice.org/bin/cygwin/make-85047eb-msvc.exe
+ cp make-85047eb-msvc.exe make
+ chmod +x make
to install from source:
place yourself in a working directory of you choice.
-git clone https://gerrit.libreoffice.org/p/gnu-make-lo.git
-cd gnu-make-lo
-autoreconf -i
-./configure --prefix=/opt/lo
-make
-make install
+ git clone git://git.savannah.gnu.org/make.git
+
+ [go to Start menu, click on "VS2012 x86 Native Tools Command Prompt"]
+ set PATH=%PATH%;C:\Cygwin\bin
+ cd .../path/to/make_git
+ build_w32.bat --without-guile
+
+should result in a WinRel/gnumake.exe
Then re-run autogen.sh