summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2014-07-16 22:49:26 +0200
committerNorbert Thiebaud <nthiebaud@gmail.com>2014-07-20 22:10:58 +0200
commit269e960ee190a8f568e99756c90cd98f1a7919ce (patch)
tree232f798a5051f203f78eac62e29438e9625ce9d6 /configure.ac
parent2d226f4c0b3f95bfdfe7bdcd3fd0ab87a806f4c3 (diff)
add config_vcl to control DevicePixel coordinate base type
The eventual goal is to make vcl capable of handling a backend that use double instead of sal_Int32 as its base type for device coordinate. Change-Id: I6174f1f4afe00992b95c9163bc21dd54fec98631
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1eda25eddd5..c3373853f1df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10077,6 +10077,18 @@ if ! "$TOUCH" -h warn 2>/dev/null > /dev/null; then
fi
dnl ===================================================================
+dnl Set vcl option: coordinate device in double or sal_Int32
+dnl ===================================================================
+
+AC_MSG_CHECKING([Type to use for Device Pixel coordinates])
+if test "$_os" = "Darwin" -o $_os = iOS ; then
+ AC_DEFINE(VCL_FLOAT_DEVICE_PIXEL)
+ AC_MSG_RESULT([double])
+else
+ AC_MSG_RESULT([sal_Int32])
+fi
+
+dnl ===================================================================
dnl Test which vclplugs have to be built.
dnl ===================================================================
R=""
@@ -13053,6 +13065,7 @@ AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_test.h])
AC_CONFIG_HEADERS([config_host/config_telepathy.h])
AC_CONFIG_HEADERS([config_host/config_typesizes.h])
+AC_CONFIG_HEADERS([config_host/config_vcl.h])
AC_CONFIG_HEADERS([config_host/config_vclplug.h])
AC_CONFIG_HEADERS([config_host/config_version.h])
AC_CONFIG_HEADERS([config_host/config_oauth2.h])