summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-05-31 14:14:48 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-06-01 14:22:16 +0200
commitfc988abb4110112be48e80320ddce69961b9a83a (patch)
treeb8c2079ed04b09d7b6de17b65438df6ec67211fb /configure.ac
parent8d3b0d35e67bfdaa3961931bfb70dfd87668718e (diff)
--enable-gio also for --disable-gtk --enable-gtk3
...as is used by the Flatpak build. Other settings only checked in that block controlled by ENABLE_GTK, and thus potentially erronously left empty for --disable-gtk --enable-gtk3 builds, are GTHREAD- and GTK_PRINT-related settings. GTHREAD_LIBS is explicitly used in vcl/Library_vclplug_gtk3.mk even, but it being empty apparently has no negative effects, so leave it at that for now. On the GTK_PRINT-related settings, Caolan commented on IRC: "ENABLE_GTK_PRINT is probably best removed entirely I guess, it didn't work out and they're redoing the dialog in upstream gtk again I'm told." Change-Id: I7e026c0ac9b23e7ace2c2e92390bdcc3be7d39a3 Reviewed-on: https://gerrit.libreoffice.org/55127 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com> (cherry picked from commit b5dd045bf533a2ba4d1c98debe5a2acba4c8b486) Reviewed-on: https://gerrit.libreoffice.org/55162
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8bf75c8c4d3b..a3b9107477b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10129,7 +10129,9 @@ if test "$test_gtk" = "yes"; then
GTK_PRINT_CFLAGS=$(printf '%s' "$GTK_PRINT_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTK_PRINT_LIBS}"
GTK_PRINT_LIBS="${filteredlibs}"
+ fi
+ if test "$ENABLE_GTK" = "TRUE" || test "$ENABLE_GTK3" = "TRUE"; then
AC_MSG_CHECKING([whether to enable GIO support])
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gio" = "yes"; then
dnl Need at least 2.26 for the dbus support.