summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-11-07 10:43:14 +0100
committerCaolán McNamara <caolanm@redhat.com>2018-11-21 22:26:29 +0100
commitb73450caef299d38350f446d914f45b7c23a25b7 (patch)
treee346b7eeefb0a3d6cf0b685cab80871c89c68ec4 /configure.ac
parentbcacc66e2d1331767da77b24b3d933d4e46533a6 (diff)
tdf#121131: Default COMPILER_PLUGINS_CXX to g++ -std=c++11
ab8bf5533f8de9bb1aa9dc83e650e4eccf0fcac3 "Avoid error message from configure about clang's header for compiler plugins" caused problems after cd472d1d8489f30797f47d3f6dafede28c1feb90 "Compile as C++2a, where available", when the compiler used to build LO (CXX) supports -std=gnu++2a but the compiler used to build loplugin (COMPILER_PLUGINS_CXX) does not. So solve that problem instead by just adding -std=c++11 to the default for COMPILER_PLUGINS_CXX. Change-Id: I95e86bc28f2a0dfb2b7bdce6b15955b870428b8c Reviewed-on: https://gerrit.libreoffice.org/62997 Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de> Reviewed-by: Luboš Luňák <l.lunak@collabora.com> Tested-by: Jenkins (cherry picked from commit 4613e105f98af6e3b65ce87432b1a2db45e71ae2) Reviewed-on: https://gerrit.libreoffice.org/63714
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a158e7f80bcf..f1c76828a4df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6601,9 +6601,9 @@ if test "$COM_IS_CLANG" = "TRUE"; then
save_CPPFLAGS=$CPPFLAGS
save_CXX=$CXX
# compiler plugins must be built with "native" compiler that was used to build Clang itself:
- : "${COMPILER_PLUGINS_CXX=g++}"
+ : "${COMPILER_PLUGINS_CXX=g++ -std=c++11}"
CXX=$COMPILER_PLUGINS_CXX
- CPPFLAGS="$CPPFLAGS $CXXFLAGS_CXX11 -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
+ CPPFLAGS="$CPPFLAGS -I$CLANGDIR/include -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS"
AC_CHECK_HEADER(clang/AST/RecursiveASTVisitor.h,
[COMPILER_PLUGINS=TRUE],
[