summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-05-08 15:16:18 +0200
committerStephan Bergmann <sbergman@redhat.com>2018-05-08 16:53:54 +0200
commit946ef03274d723d8fb1fd3d24e8160aa91c3ed39 (patch)
tree1d7858d6c95e5305ae18bc2d7cd77da163865b93 /configure.ac
parentccbb507002b2bf20689def23066521506a1e9c2b (diff)
Prevent potential issues mixing system/non-system libwps and libnumbertext
Change-Id: I1e47b3cc01df3d204ef7ef36f2432830aa18e65e Reviewed-on: https://gerrit.libreoffice.org/53978 Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Tested-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50e96287124f..c5f0edc9eb7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3813,6 +3813,21 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_gpgmepp=no
fi
+ # As mixing system libwps and non-system libnumbertext or vice versa likely causes trouble (see
+ # 603074c5f2b84de8a24593faf807da784b040625 "Pass _GLIBCXX_DEBUG into external/libwps" and the
+ # mail thread starting at <https://gcc.gnu.org/ml/gcc/2018-05/msg00057.html> "libstdc++: ODR
+ # violation when using std::regex with and without -D_GLIBCXX_DEBUG"), simply make sure neither
+ # of those two is using the system variant:
+ if test "$with_system_libnumbertext" = "yes"; then
+ AC_MSG_ERROR([--with-system-libnumbertext conflicts with --enable-dbgutil])
+ else
+ with_system_libnumbertext=no
+ fi
+ if test "$with_system_libwps" = "yes"; then
+ AC_MSG_ERROR([--with-system-libwps conflicts with --enable-dbgutil])
+ else
+ with_system_libwps=no
+ fi
else
ENABLE_DBGUTIL=""
MSVC_USE_DEBUG_RUNTIME=""