summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2019-02-19 09:32:46 +0100
committerMichael Weghorn <m.weghorn@posteo.de>2019-02-19 09:32:46 +0100
commit88d8736b053a6d43572d26942a3c79d1917178a9 (patch)
treeea408fc624220e3fcc1ef976523758785ea53594 /configure.ac
parentc4f0a9dbe4aa4d3f418971b62b82620fe5e203d4 (diff)
parentcf41dff97e6b7c69d6a5efd6be95e0926d3770dd (diff)
Merge branch 'temp/libreoffice-6-1'
into distro/lhm/libreoffice-6-1+backports The merged 'temp/libreoffice-6-1' corresponds to the upstream 'libreoffice-6-1" branch except for the revert of 736a38419f49d4b96bd845f5767a028df59e4cff, for which the corresponding master commit will be cherry-picked after merge instead. Conflicts: sc/qa/unit/subsequent_export-test.cxx Change-Id: I1e79bd2c018d06a945d576a8054350aa459b6762
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2ae3d00a6478..902305e2cccf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,7 +9,7 @@ dnl in order to create a configure script.
# several non-alphanumeric characters, those are split off and used only for the
# ABOUTBOXPRODUCTVERSIONSUFFIX in openoffice.lst. Why that is necessary, no idea.
-AC_INIT([LibreOffice],[6.1.5.0.0+],[],[],[http://documentfoundation.org/])
+AC_INIT([LibreOffice],[6.1.6.0.0+],[],[],[http://documentfoundation.org/])
AC_PREREQ([2.59])
@@ -807,13 +807,6 @@ haiku*)
;;
esac
-if test "$_os" != "WINNT"; then
-AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
-else
-ENDIANNESS=little
-fi
-AC_SUBST(ENDIANNESS)
-
if test "$_os" = "Android" ; then
# Verify that the NDK and SDK options are proper
if test -z "$with_android_ndk"; then
@@ -929,7 +922,7 @@ my_original_CXXFLAGS=$CXXFLAGS
my_original_CPPFLAGS=$CPPFLAGS
dnl The following checks for gcc, cc and then cl (if it weren't guarded for win32)
-dnl Needs to precede the AC_SEARCH_LIBS call below, which apparently calls
+dnl Needs to precede the AC_C_BIGENDIAN and AC_SEARCH_LIBS calls below, which apparently call
dnl AC_PROG_CC internally.
if test "$_os" != "WINNT"; then
# AC_PROG_CC sets CFLAGS to -g -O2 if not set, avoid that
@@ -938,6 +931,13 @@ if test "$_os" != "WINNT"; then
CFLAGS=$save_CFLAGS
fi
+if test "$_os" != "WINNT"; then
+AC_C_BIGENDIAN([ENDIANNESS=big], [ENDIANNESS=little])
+else
+ENDIANNESS=little
+fi
+AC_SUBST(ENDIANNESS)
+
if test $_os != "WINNT"; then
save_LIBS="$LIBS"
AC_SEARCH_LIBS([dlsym], [dl],
@@ -8297,7 +8297,7 @@ internal)
SYSTEM_PYTHON=
PYTHON_VERSION_MAJOR=3
PYTHON_VERSION_MINOR=5
- PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.5
+ PYTHON_VERSION=${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}.6
if ! grep -q -i python.*${PYTHON_VERSION} ${SRC_ROOT}/download.lst; then
AC_MSG_ERROR([PYTHON_VERSION ${PYTHON_VERSION} but no matching file in download.lst])
fi