summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjan Iversen <jani@libreoffice.org>2017-06-09 19:42:11 +0200
committerjan Iversen <jani@libreoffice.org>2017-06-11 12:45:52 +0200
commitcdc3ddb487fe5ab164075eafe19e5dc7e83ba7b5 (patch)
treedaa05dba85743136427270584cc8a34fe533cc1f /configure.ac
parenta18351ae2c90ff88cc9134ef3308fc2315ebcc09 (diff)
iOS, updated configure.ac to allow native armv7 and arm64
Added manual sizeof since AC_CHECK_SIZE does not work bypassed clang test for static initializers (works for i386) Change-Id: Ia766ee980c1184767315cbd476750cd0c82c7263
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1bdb40ce2c30..4a96e9370c7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5626,12 +5626,32 @@ dnl ===================================================================
if test "$_os" != "WINNT"; then
+if test "$_os" == "iOS"; then
+if test "$host_cpu" == "armv7"; then
+ ac_cv_sizeof_long=4
+ ac_cv_sizeof_short=2
+ ac_cv_sizeof_int=4
+ ac_cv_sizeof_long_long=8
+ ac_cv_sizeof_double=8
+ ac_cv_sizeof_voidp=4
+else
+ ac_cv_sizeof_long=8
+ ac_cv_sizeof_short=2
+ ac_cv_sizeof_int=4
+ ac_cv_sizeof_long_long=8
+ ac_cv_sizeof_double=8
+ ac_cv_sizeof_voidp=8
+fi
+AC_MSG_CHECKING([iOS setting sizes long, short, int, long long, double, voidp])
+
+else
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(double)
AC_CHECK_SIZEOF(void*)
+fi
SAL_TYPES_SIZEOFSHORT=$ac_cv_sizeof_short
SAL_TYPES_SIZEOFINT=$ac_cv_sizeof_int
@@ -12223,7 +12243,7 @@ AC_LANG_POP([C++])
LIBS=$save_LIBS
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$broken])
-if test "$broken" = yes; then
+if test "$broken" = yes -a "$_os" != "iOS"; then
AC_MSG_ERROR([working support for static initializer_list needed])
fi