summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2013-10-07 23:19:08 +0200
committerThorsten Behrens <thb@documentfoundation.org>2013-10-07 21:29:26 +0000
commit6019a157512fb3182c165e8264e9d4024b76b280 (patch)
tree7803183e486c22a547ed7e2431115754827bdf8c /configure.ac
parent47e1f1eb505cb8cbcb23069893bc7c430b5621e2 (diff)
only build openGL canvas when libGL supports shader
and disable for Mac until code is adjusted to compile Change-Id: I48c69962ae5e59ae3bdd35d343deeeffdde6e903 Reviewed-on: https://gerrit.libreoffice.org/6160 Reviewed-by: Thorsten Behrens <thb@documentfoundation.org> Tested-by: Thorsten Behrens <thb@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1da0a2e5909f..c351f0b7f9c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10263,11 +10263,14 @@ if test "x$enable_opengl" = "xno"; then
elif test "$_os" = "Darwin"; then
# We use frameworks on Mac OS X, no need for detail checks
ENABLE_OPENGL=TRUE
+ ENABLE_OPENGL_CANVAS=
+ add_warning "openGL canvas not adapted for Mac yet - disabling"
SYSTEM_MESA_HEADERS=YES
AC_MSG_RESULT([yes])
elif test $_os = WINNT; then
# Experimental: try to use OpenGL on Windows
ENABLE_OPENGL=TRUE
+ ENABLE_OPENGL_CANVAS=TRUE
# We need the internal "Mesa" headers.
SYSTEM_MESA_HEADERS=NO
BUILD_TYPE="$BUILD_TYPE MESA"
@@ -10276,8 +10279,12 @@ else
save_LDFLAGS=$LDFLAGS
LDFLAGS="$LDFLAGS -lm"
AC_MSG_RESULT([yes])
- AC_CHECK_LIB([GL], [main], [:],
- [AC_MSG_ERROR(libGL not installed or functional)], [])
+ AC_CHECK_LIB([GL], [main],
+ [AC_CHECK_LIB([GL], [glCreateShader], [ENABLE_OPENGL_CANVAS=TRUE],
+ [add_warning "no shader support in libGL - will enable openGL transitions, but not openGL canvas"
+ AC_MSG_WARN([no shader support in libGL - will enable openGL transitions, but not openGL canvas])
+ ENABLE_OPENGL_CANVAS=], [])],
+ [AC_MSG_ERROR(libGL not installed or functional)], [])
LDFLAGS="$LDFLAGS -lGL"
AC_CHECK_LIB([GLU], [main], [:],
[AC_MSG_ERROR(libGLU not installed or functional)], [])
@@ -10306,6 +10313,7 @@ fi
AC_SUBST(SYSTEM_MESA_HEADERS)
AC_SUBST(ENABLE_OPENGL)
+AC_SUBST(ENABLE_OPENGL_CANVAS)
dnl =================================================
dnl Check whether to build with OpenCL support.