summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-06-16 09:46:39 +0200
committerStephan Bergmann <sbergman@redhat.com>2017-06-16 10:33:59 +0200
commit579497164f6bddfeb14bb6b0f4b9cd3322af1803 (patch)
tree325bdbcae65ae2e9afe1dd3d56de2f16ec06f0b4 /configure.ac
parentfcd12c6d8574c1cd4c6ff45ba54e5d286d42eaad (diff)
Bump GCC baseline to 4.8.1
see <https://lists.freedesktop.org/archives/libreoffice/2017-June/077909.html> "Re: Some baseline thoughts" and <https://lists.freedesktop.org/archives/libreoffice/2017-June/077910.html> "minutes of ESC call ..." Change-Id: I09fb8dc228c23a39e7e332742095b0e2dfce711d Reviewed-on: https://gerrit.libreoffice.org/38860 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e82c61d86424..15272b766644 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3780,12 +3780,14 @@ dnl ===================================================================
if test "$GCC" = "yes" -a -z "$COM_IS_CLANG"; then
AC_MSG_CHECKING([the GCC version])
_gcc_version=`$CC -dumpversion`
+ gcc_full_version=$(printf '%s' "$_gcc_version" | \
+ $AWK -F. '{ print $1*10000+$2*100+$3 }')
GCC_VERSION=`echo $_gcc_version | $AWK -F. '{ print \$1*100+\$2 }'`
- AC_MSG_RESULT([gcc $_gcc_version])
+ AC_MSG_RESULT([gcc $_gcc_version ($gcc_full_version)])
- if test "$GCC_VERSION" -lt 0407; then
- AC_MSG_ERROR([GCC $_gcc_version is too old, must be at least GCC 4.7.0])
+ if test "$gcc_full_version" -lt 40801; then
+ AC_MSG_ERROR([GCC $_gcc_version is too old, must be at least GCC 4.8.1])
fi
else
# Explicitly force GCC_VERSION to be empty, even for Clang, to check incorrect uses.