summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-10-10 09:38:58 +0300
committerTor Lillqvist <tml@collabora.com>2013-10-10 09:56:23 +0300
commit46ddcbbe2a4b2e97770f2c962c6450a48f539cd9 (patch)
tree9b9d97672d9b4b58fca5eb497c4015a320d18348 /configure.ac
parentcd40d2ba9e8ed17cc870606b17ac2dffceb2813d (diff)
Normalize ENABLE_PDFIMPORT: TRUE or empty
Change-Id: I962b37757dbf3569df73e70ae2d7c666d7cdf43e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f6c0c01bcd44..8055daee9a6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -773,6 +773,11 @@ AC_ARG_ENABLE(lpsolve,
[Disable compilation of the lp solve solver ])
)
+AC_ARG_ENABLE(pdfimport,
+ AS_HELP_STRING([--disable-pdfimport],
+ [Disable building the PDF import feature.])
+)
+
###############################################################################
dnl ---------- *** ----------
@@ -4514,11 +4519,11 @@ if test "$cross_compiling" = "yes"; then
# Don't bother having configure look for stuff not needed for the build platform anyway
./configure \
--disable-graphite \
+ --disable-pdfimport \
--disable-postgresql-sdbc \
--with-parallelism="$with_parallelism" \
--without-doxygen \
--without-java \
- ENABLE_PDFIMPORT=FALSE \
$sub_conf_opts \
--srcdir=$srcdir \
2>&1 | sed -e 's/^/ /'
@@ -10347,15 +10352,16 @@ fi
AC_SUBST(ENABLE_MINIMIZER)
# pdf import?
-AC_MSG_CHECKING([whether to build the PDF import])
-if test "$_os" != Android -a "$_os" != iOS -a "$ENABLE_PDFIMPORT" != FALSE; then
+AC_MSG_CHECKING([whether to build the PDF import feature])
+ENABLE_PDFIMPORT=
+if test $_os != Android -a $_os != iOS -a \( -z "$enable_pdfimport" -o "$enable_pdfimport" = yes \); then
AC_MSG_RESULT([yes])
ENABLE_PDFIMPORT=TRUE
dnl ===================================================================
dnl Check for system poppler
dnl ===================================================================
- AC_MSG_CHECKING([which pdf backend to use])
+ AC_MSG_CHECKING([which PDF import backend to use])
if test "$with_system_poppler" = "yes"; then
AC_MSG_RESULT([external])
SYSTEM_POPPLER=YES
@@ -10379,7 +10385,6 @@ if test "$_os" != Android -a "$_os" != iOS -a "$ENABLE_PDFIMPORT" != FALSE; then
fi
else
AC_MSG_RESULT([no])
- ENABLE_PDFIMPORT=FALSE
fi
AC_SUBST(ENABLE_PDFIMPORT)
AC_SUBST(SYSTEM_POPPLER)
@@ -12492,7 +12497,7 @@ if test "$enable_mpl_subset" = "yes"; then
if test "x$enable_ext_mariadb_connector" = "xyes"; then
AC_MSG_ERROR([need to --disable-ext-mariadb-connector - mariadb/mysql support.])
fi
- if test "x$ENABLE_PDFIMPORT" != "xFALSE"; then
+ if test -n "$ENABLE_PDFIMPORT"; then
if test "x$SYSTEM_POPPLER" != "xNO"; then
AC_MSG_ERROR([need to disable PDF import via poppler or use system library])
fi