summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2013-10-06 16:29:04 +0200
committerRene Engelhard <rene@debian.org>2013-10-06 16:29:20 +0200
commit2c5faba2a34d5feb9a6ea9d4fd9bf94ce914a19d (patch)
tree070736ed9acc1c3451e98f015fbb779977987f2d /configure.ac
parenta781ae0bb8a144a8be505dcb1e81b9b30bc250c9 (diff)
make system-bluez build not use -I$S/bluez_bluetooth/inc in sd...
Change-Id: Icdd90a7aadf7cfbc464e11a1e0386576cbc5c06c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1cf6c53a2129..c98b42c42a8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10031,28 +10031,34 @@ if test -n "$enable_sdremote" -a "$enable_sdremote" != "no"; then
AC_MSG_RESULT([external])
AC_CHECK_HEADER(bluetooth/bluetooth.h, [],
[AC_MSG_ERROR(bluetooth.h not found. install bluez)], [])
+ SYSTEM_BLUEZ=YES
else
AC_MSG_RESULT([internal])
- BUILD_TYPE="$BUILD_TYPE BLUEZ"
+ SYSTEM_BLUEZ=NO
fi
else
AC_MSG_RESULT([no, dbus disabled])
ENABLE_SDREMOTE_BLUETOOTH=
+ SYSTEM_BLUEZ=NO
fi
else
AC_MSG_RESULT([yes])
ENABLE_SDREMOTE_BLUETOOTH=TRUE
+ SYSTEM_BLUEZ=NO
fi
else
AC_MSG_RESULT([no])
ENABLE_SDREMOTE_BLUETOOTH=
+ SYSTEM_BLUEZ=NO
fi
else
ENABLE_SDREMOTE=
+ SYSTEM_BLUEZ=NO
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_SDREMOTE)
AC_SUBST(ENABLE_SDREMOTE_BLUETOOTH)
+AC_SUBST(SYSTEM_BLUEZ)
dnl ===================================================================
dnl Check whether the gtk 2.0 libraries are available.