summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-08-28 02:23:37 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2017-05-19 03:43:19 +0200
commit27e63fa4c95e5f756ac8dc5029e7bdba36e69a8b (patch)
tree26519faefaffed8fd83486c78261b538b41558d8 /configure.ac
parent132c9f88f55e2ce2ee9e66b9c6bbd9cd6037b36a (diff)
add configure setting for the update channel
This only makes sense with the mar based updater and is currently only used for uploading the builds. Change-Id: I8baec67419bd1042e89d0373ca868973b23d8a5f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8e38624282f7..a5ad53b18e24 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1382,6 +1382,10 @@ libo_FUZZ_ARG_ENABLE(online-update,
If the value is "mar", the experimental Mozilla-like update will be
enabled instead of the traditional update mechanism.]),
,)
+AC_ARG_WITH(update-channel,
+ AS_HELP_STRING([--with-update-channel=master-daily],
+ [Defines the update channel used by the updater.]),
+,with_update_channel=master-daily)
libo_FUZZ_ARG_ENABLE(extension-update,
AS_HELP_STRING([--disable-extension-update],
@@ -11303,6 +11307,7 @@ dnl ===================================================================
AC_MSG_CHECKING([whether to enable online update])
ENABLE_ONLINE_UPDATE=
ENABLE_ONLINE_UPDATE_MAR=
+UPDATE_CHANNEL=
if test "$enable_online_update" = ""; then
if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
AC_MSG_RESULT([yes])
@@ -11315,6 +11320,7 @@ else
AC_MSG_RESULT([yes - MAR-based online update])
ENABLE_ONLINE_UPDATE_MAR="TRUE"
AC_DEFINE(HAVE_FEATURE_UPDATE_MAR)
+ UPDATE_CHANNEL="$with_update_channel"
elif test "$enable_online_update" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
@@ -11324,6 +11330,7 @@ else
fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
+AC_SUBST(UPDATE_CHANNEL)
dnl ===================================================================
dnl Test whether we need bzip2