summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbrainbreaker <gautamprajapati06@gmail.com>2017-06-22 23:42:48 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-07-10 18:03:48 +0200
commit271882910107e177bc98af877f9c8b9f89c09795 (patch)
treeff465f3f07a92793cf9889561e2f8cb250254913 /configure.ac
parent206ca28bed4bf69b5ade53ae154bc5c88a17ddce (diff)
android: update configure.ac to support building only with NDK>=15
Change-Id: I638019895921082b9da36315c2f6d3ed98e5249a Reviewed-on: https://gerrit.libreoffice.org/39127 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0eb7ed7150a1..5d34221b7232 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,12 +381,16 @@ if test -n "$with_android_ndk"; then
fi
case $ANDROID_NDK_VERSION in
r9*|r10*)
+ AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.0.*])
;;
- 11.1.*|12.1.*|13.1.*|14.1.*|15.0*)
+ 11.1.*|12.1.*|13.1.*|14.1.*)
+ AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.0.*])
+ ;;
+ 15.0.*)
;;
*)
- AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 15.0.* have been used successfully. Proceed at your own risk.])
- add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only versions r9* til 15.0.* have been used successfully. Proceed at your own risk."
+ AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* have been used successfully. Proceed at your own risk.])
+ add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* have been used successfully. Proceed at your own risk."
;;
esac