summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-10-23 22:04:36 +0200
committerMichael Stahl <mstahl@redhat.com>2013-10-24 00:24:14 +0200
commit25f65f26a25e1ca275e54b9f62c45c7e872adec9 (patch)
tree39a7d1805d48d5071bd56203f0975db5902f9d4a /configure.ac
parentb177b3067539f6c80f223b08ec772b174e721e8e (diff)
lcms2: use libraries from WORKDIR
Change-Id: Ieddc80d510884eeb6f64325f9dfbb34f1d3fb0b5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6e59d122f323..ad72a5c2856a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7791,10 +7791,13 @@ if test "$with_system_lcms2" = "yes"; then
else
SYSTEM_LCMS2=NO
fi
-libo_CHECK_SYSTEM_MODULE([lcms2],[LCMS2],[lcms2],["-I${WORKDIR}/UnpackedTarball/lcms2/include"],["-L${OUTDIR}/lib -llcms2"])
+libo_CHECK_SYSTEM_MODULE([lcms2],[LCMS2],[lcms2],["-I${WORKDIR}/UnpackedTarball/lcms2/include"],["-L${WORKDIR}/UnpackedTarball/lcms2/src/.libs -llcms2"])
if test "$GCC" = "yes"; then
LCMS2_CFLAGS="${LCMS2_CFLAGS} -Wno-long-long"
fi
+if test "$COM" = "MSC"; then # override the above
+ LCMS2_LIBS=${WORKDIR}/UnpackedTarball/lcms2/bin/lcms2.lib
+fi
dnl ===================================================================
dnl Check for system cppunit