summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-10-24 13:01:43 +0200
committerMichael Stahl <mstahl@redhat.com>2013-10-24 13:10:39 +0200
commit19d7c0348d7caadc42d557eb6d7a93446c7cd698 (patch)
tree84b6ff6646a6127f32a75e586e57e803d88a0c4f /configure.ac
parentb308526fbc07753aca7186ab84e92ae8d56d7652 (diff)
epm: use executables from WORKDIR and clean up configure
Change-Id: I69e75dbbaa16b6dc407a69ba8137c09888db50ce
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ad72a5c2856a..e1d612430297 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7362,6 +7362,7 @@ if test "$enable_epm" = "yes"; then
if test "$EPM" = "no" -o "$EPM" = "internal"; then
echo "EPM will be built."
BUILD_TYPE="$BUILD_TYPE EPM"
+ EPM=${WORKDIR}/UnpackedTarball/epm/epm
else
# Gentoo has some epm which is something different...
AC_MSG_CHECKING([whether the found epm is the right epm])
@@ -7377,8 +7378,7 @@ if test "$enable_epm" = "yes"; then
AC_MSG_RESULT([OK, >= 3.7])
else
AC_MSG_RESULT([too old. epm >= 3.7 is required.])
- echo "EPM will be built."
- BUILD_TYPE="$BUILD_TYPE EPM"
+ AC_MSG_ERROR([Install ESP Package Manager (http://www.msweet.org/projects.php?Z2) and/or specify the path to the right epm])
fi
fi
fi
@@ -7428,7 +7428,7 @@ if test "$enable_epm" = "yes"; then
fi
if echo "$PKGFORMAT" | $EGREP rpm 2>&1 >/dev/null || \
echo "$PKGFORMAT" | $EGREP pkg 2>&1 >/dev/null; then
- if test "$EPM" != "no" -a "$EPM" != "internal"; then
+ if test "$with_epm" = "no" -a "$_os" != "Darwin"; then
if test "`echo $EPM_VERSION | cut -d'.' -f1`" -lt "4"; then
AC_MSG_CHECKING([whether epm is patched for LibreOffice's needs])
if grep "Patched for LibreOffice" $EPM >/dev/null 2>/dev/null; then