summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-10-24 01:01:22 +0300
committerTor Lillqvist <tml@collabora.com>2013-10-24 01:05:02 +0300
commit0f803f73f938087424eb3aa5f870e70b1c249d73 (patch)
treeff9e2ec1bee6569c4eddb9c1d4dacf9c55accba2 /configure.ac
parent75b7ce9c66c682564b3cc15ffb7914ad5e432298 (diff)
Enforce avoiding looking for non-existent system dicts on OS X and Windows
It is totally pointless to look for "system" /usr/share/myspell, hyphen and mythes dictionaries on systems where they don't exist. Use only bundled dictionaries. (For OS X, we have code to use a system-specific spell checking API.) Change-Id: I13aed7225d003e608f61de95671feb2e50b26c25
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bacf5087bda..6e59d122f323 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4760,6 +4760,14 @@ else
fi
AC_SUBST(WITH_MYSPELL_DICTS)
+# There are no "system" myspell, hyphen or mythes dictionaries on OS X, Windows, Android or iOS.
+if test $_os = Darwin -o $_os = WINNT -o $_os = iOS -o $_os = Android; then
+ if test "$with_system_dicts" = yes; then
+ AC_MSG_ERROR([There are no system dicts on this OS in the formats the 3rd-party libs we use expect]);
+ fi
+ with_system_dicts=no
+fi
+
AC_MSG_CHECKING([whether to use dicts from external paths])
if test -z "$with_system_dicts" -o "$with_system_dicts" != "no"; then
AC_MSG_RESULT([yes])