summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2018-12-13 09:43:55 +0100
committerJan Holesovsky <kendy@collabora.com>2019-06-17 10:15:14 +0200
commit59ffa0b68eec6b11f0453d69a1086457b31a5cbc (patch)
tree92a6472b0215fe0d2175b820b1fb18f8e0f4718b /configure.ac
parent9652e4aa42d94d3c9e8723d58ec12f5d7ffe097f (diff)
Introduce --enable-android-editing
...to select the experimental ...Editing... Android build variant. (Ignored for non-Android builds, but using libo_FUZZ_ARG_ENABLE anyway, just in case.) Change-Id: I670925ff358039e38edc29db69f48a78d484f133 Reviewed-on: https://gerrit.libreoffice.org/65077 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-on: https://gerrit.libreoffice.org/74148 Reviewed-by: Jan Holesovsky <kendy@collabora.com> Tested-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6687a8d54ff3..eb510df19335 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,6 +522,16 @@ if test -n "$with_android_sdk"; then
fi
AC_SUBST(ANDROID_SDK_HOME)
+libo_FUZZ_ARG_ENABLE([android-editing],
+ AS_HELP_STRING([--enable-android-editing],
+ [Enable the experimental editing feature on Android.])
+)
+ENABLE_ANDROID_EDITING=
+if test "$enable_android_editing" = yes; then
+ ENABLE_ANDROID_EDITING=TRUE
+fi
+AC_SUBST([ENABLE_ANDROID_EDITING])
+
dnl ===================================================================
dnl The following is a list of supported systems.
dnl Sequential to keep the logic very simple