summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRiccardo Magliocchetti <riccardo.magliocchetti@gmail.com>2013-05-06 12:55:22 +0200
committerMichael Stahl <mstahl@redhat.com>2013-05-16 13:48:42 +0000
commitfbdfd76d357ef82cacafdf12228b0025374fbc20 (patch)
tree794e46b60379ff7e7c336fe5e24befc54fb3d741 /configure.ac
parent0fd4d12c6233da2ac1936cd89838b006ffec5192 (diff)
configure: check libjpeg having JERR_BAD_CROP_SPEC defined
b5a9cc71 introduced the use of JERR_BAD_CROP_SPEC which is not available in Ubuntu 11.10 version of libjpeg62. So better catch this at configure time. Change-Id: I19e4287b0c1a9ddc0baaa70ab61364f99571682c Reviewed-on: https://gerrit.libreoffice.org/3796 Reviewed-by: Michael Stahl <mstahl@redhat.com> Tested-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49e8d025931c..556f94627e28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7135,6 +7135,17 @@ if test "$with_system_jpeg" = "yes"; then
[AC_MSG_ERROR(jpeg.h not found. install libjpeg)], [])
AC_CHECK_LIB(jpeg, jpeg_resync_to_restart, [ JPEG3RDLIB=-ljpeg ],
[AC_MSG_CHECKING(jpeg library not found or fuctional)], [])
+ AC_MSG_CHECKING([[libjpeg version is 7 or greater]])
+ AC_COMPILE_IFELSE([ AC_LANG_SOURCE(
+ [[
+#include <stdio.h>
+#include <jerror.h>
+int main(int c, char**v) { printf("%d\n", JERR_BAD_CROP_SPEC); return 0; }
+ ]]) ],
+ [AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)
+ AC_MSG_ERROR(jpeg library version >= 7 required)
+ ])
libo_MINGW_CHECK_DLL([libjpeg])
else
AC_MSG_RESULT([internal])