summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2013-05-15 16:04:31 +0200
committerMichael Meeks <michael.meeks@suse.com>2013-05-15 16:14:21 +0100
commit0c99c1c2cafabf72b7cb32fc313441e52fd2876a (patch)
tree2cde382ce7cfe84bf19ef92aeeced41019d60cd5 /configure.ac
parentfbf2e9f733e1e5b6c9d2cdada0317c89c1a3b71f (diff)
gallery: allow disabling the from-source build in configure
Change-Id: Ic390ceeb9f52953d5dea6999b194956e90eb4629
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 36 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62b6315ec680..91737baffe2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1215,6 +1215,14 @@ AC_ARG_WITH(referenced-git,
GIT_REFERENCE_SRC=$withval ,
)
+AC_ARG_WITH(galleries,
+ AS_HELP_STRING([--with-galleries],
+ [Specify how galleries should be built. It is possible either to
+ build these internally from source ("build"), or to (optionally
+ download and) unpack them them from a package ("package"), or
+ to disable them ("no")]),
+)
+
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
@@ -2201,6 +2209,34 @@ fi
AC_SUBST(SYSBASE)
dnl ===================================================================
+dnl Sort out various gallery compilation options
+dnl ===================================================================
+AC_MSG_CHECKING([how to build and package galleries])
+if test -n "${with_galleries}"; then
+ if test "$with_galleries" = "build"; then
+ WITH_GALLERY_BUILD=YES
+ AC_MSG_RESULT([build from source images internally])
+ elif test "$with_galleries" = "package"; then
+ WITH_GALLERY_BUILD=PACKAGE
+ AC_MSG_ERROR([FIXME - implement build from pre-compiled package])
+ elif test "$with_galleries" = "no"; then
+ WITH_GALLERY_BUILD=
+ AC_MSG_RESULT([disable non-internal gallery build])
+ else
+ AC_MSG_ERROR([unknown value --with-galleries=$with_galleries])
+ fi
+else
+ if test $_os != iOS -a $_os != Android; then
+ WITH_GALLERY_BUILD=YES
+ AC_MSG_RESULT([internal src images for desktop])
+ else
+ WITH_GALLERY_BUILD=
+ AC_MSG_RESULT([disable src imgage build for non-desktop])
+ fi
+fi
+AC_SUBST(WITH_GALLERY_BUILD)
+
+dnl ===================================================================
dnl Checks if ccache is available
dnl ===================================================================
if test "$enable_ccache" = "yes" -o \( "$enable_ccache" = "" -a "$enable_icecream" != "yes" \); then