summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-06-23 00:52:38 +0300
committerTor Lillqvist <tml@collabora.com>2020-11-13 13:25:57 +0100
commitf7f122f34183ce79b1337d8e2a6bc32f4c865f83 (patch)
treea5c43925da591731b1439f75fdb21c760080353d /configure.ac
parentb62725ad8afa6fe9c426f968287b9e3528eb8268 (diff)
Accept macOS SDK 11.0
Change-Id: I92275eabe3c6a9442f675ec211c1dd1a8b58bd1b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/96909 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/105787 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index c079302a6df2..0ce51d381e08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2809,7 +2809,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-10.15 10.14 10.13 10.12}; do
+ for _macosx_sdk in ${with_macosx_sdk-11.0 10.15 10.14 10.13 10.12}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2841,8 +2841,11 @@ if test $_os = Darwin; then
10.15)
MACOSX_SDK_VERSION=101500
;;
+ 11.0)
+ MACOSX_SDK_VERSION=110000
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--15])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--11.0])
;;
esac
@@ -2890,8 +2893,11 @@ if test $_os = Darwin; then
10.15)
MAC_OS_X_VERSION_MIN_REQUIRED="101500"
;;
+ 11.0)
+ MAC_OS_X_VERSION_MIN_REQUIRED="110000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--15])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.0])
;;
esac
MAC_OS_X_VERSION_MIN_REQUIRED_DOTS=$with_macosx_version_min_required
@@ -2943,8 +2949,11 @@ if test $_os = Darwin; then
10.15)
MAC_OS_X_VERSION_MAX_ALLOWED="101500"
;;
+ 11.0)
+ MAC_OS_X_VERSION_MAX_ALLOWED="110000"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--15])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.0])
;;
esac