summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2019-09-23 14:13:13 +0300
committerTor Lillqvist <tml@collabora.com>2019-09-23 14:43:53 +0300
commit8b86d412051041093540a25e1e19c1322a68cb7a (patch)
tree207fa5e3818011796b3cdbe31176afaa35f4de2a /configure.ac
parent3e74d12e588d1cd382a04bb028f599f1d682069b (diff)
This if branch is for macOS, not iOS
Change-Id: I4a502d4247bf86fd2bc5734a64e600ae0e214f21
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 51767f9c537a..13046e36cc9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2749,7 +2749,7 @@ dnl ===================================================================
dnl Check macOS SDK and compiler
dnl ===================================================================
-if test $_os = Darwin -o $_os = iOS; then
+if test $_os = Darwin; then
# If no --with-macosx-sdk option is given, look for one
@@ -2777,17 +2777,8 @@ if test $_os = Darwin -o $_os = iOS; then
AC_MSG_ERROR([Could not find an appropriate macOS SDK])
fi
- if test $_os = iOS; then
- if test "$enable_ios_simulator" = "yes"; then
- useos=iphonesimulator
- else
- useos=iphoneos
- fi
- MACOSX_SDK_PATH=`xcrun --sdk ${useos} --show-sdk-path 2> /dev/null`
- fi
AC_MSG_RESULT([SDK $with_macosx_sdk at $MACOSX_SDK_PATH])
-
case $with_macosx_sdk in
10.12)
MACOSX_SDK_VERSION=101200