summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-11-19 22:04:21 +0200
committerTor Lillqvist <tml@collabora.com>2020-11-19 21:30:25 +0100
commit411c2f5fdede197e5b8e6d942e3b35e301b1a5e5 (patch)
treee0c52739f059b47ed528a81bcb9fe95e9ffa2bac /configure.ac
parent0165bd49a2e4ead9f86ef07c14135dbe461befd2 (diff)
Allow --enable-macosx-sandbox without the codesigning identities
For cases where you just want "make test-install" to construct an app bundle that you will manipulate and then sign separately. Change-Id: Iad805618f74ec783ebc013a664f928511b388383 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/106185 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2da3ac32e21a..0d08e29fb0b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3096,11 +3096,9 @@ if test $_os = Darwin; then
AC_MSG_CHECKING([whether to sandbox the application])
- if test -z "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
- AC_MSG_ERROR([macOS sandboxing requires code signing])
- elif test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
+ if test -n "$ENABLE_JAVA" -a "$enable_macosx_sandbox" = yes; then
AC_MSG_ERROR([macOS sandboxing (actually App Store rules) disallows use of Java])
- elif test -n "$MACOSX_CODESIGNING_IDENTITY" -a "$enable_macosx_sandbox" = yes; then
+ elif test "$enable_macosx_sandbox" = yes; then
ENABLE_MACOSX_SANDBOX=TRUE
AC_DEFINE(HAVE_FEATURE_MACOSX_SANDBOX)
AC_MSG_RESULT([yes])