summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2020-12-15 12:43:29 +0200
committerTor Lillqvist <tml@collabora.com>2020-12-16 11:40:51 +0100
commit6cf26f083bb49e304a44aea4cf09287d77abc13a (patch)
tree42f5814a896482ad61051ee80fa81fd9dc897f4c /configure.ac
parent8bd601208081635890e54a000064010198c6dd2e (diff)
Accept macOS SDK 11.1
Change-Id: Ief4322005fb9087c00f767dcd50a59f2ccbc8a82 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107744 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com> Reviewed-on: https://gerrit.libreoffice.org/c/core/+/107821 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9b13e3747add..379ed382ee95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2854,7 +2854,7 @@ if test $_os = Darwin; then
# higher than or equal to the minimum required should be found.
AC_MSG_CHECKING([what macOS SDK to use])
- for _macosx_sdk in ${with_macosx_sdk-11.0 10.15 10.14 10.13 10.12}; do
+ for _macosx_sdk in ${with_macosx_sdk-11.1 11.0 10.15 10.14 10.13 10.12}; do
MACOSX_SDK_PATH=`xcrun --sdk macosx${_macosx_sdk} --show-sdk-path 2> /dev/null`
if test -d "$MACOSX_SDK_PATH"; then
with_macosx_sdk="${_macosx_sdk}"
@@ -2889,8 +2889,11 @@ if test $_os = Darwin; then
11.0)
MACOSX_SDK_VERSION=110000
;;
+ 11.1)
+ MACOSX_SDK_VERSION=110100
+ ;;
*)
- AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--11.0])
+ AC_MSG_ERROR([with-macosx-sdk $with_macosx_sdk is not a supported value, supported values are 10.12--11.1])
;;
esac
@@ -2952,8 +2955,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MIN_REQUIRED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MIN_REQUIRED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-min-required $with_macosx_version_min_required is not a supported value, supported values are 10.10--11.1])
;;
esac
MAC_OS_X_VERSION_MIN_REQUIRED_DOTS=$with_macosx_version_min_required
@@ -3018,8 +3024,11 @@ if test $_os = Darwin; then
11.0)
MAC_OS_X_VERSION_MAX_ALLOWED="110000"
;;
+ 11.1)
+ MAC_OS_X_VERSION_MAX_ALLOWED="110100"
+ ;;
*)
- AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.0])
+ AC_MSG_ERROR([with-macosx-version-max-allowed $with_macosx_version_max_allowed is not a supported value, supported values are 10.10--11.1])
;;
esac