summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2019-09-05 16:43:14 +0200
committerJan Holesovsky <kendy@collabora.com>2019-10-22 14:17:32 +0200
commit7d8f0a8fdef91f7f46fc6b5d86a169a55c934519 (patch)
treeb2ebb4249fca100f8104a4c0abfc05a88e4ad159 /configure.ac
parent016141db1deea005c7963d2f4c9e934fe2d85817 (diff)
android: add support for 64bit build
Change-Id: Id8aae84308f6128351ae2f93c8fbc8941a0c7fc6 Reviewed-on: https://gerrit.libreoffice.org/79085 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Reviewed-on: https://gerrit.libreoffice.org/81225 Tested-by: Jenkins CollaboraOffice <jenkinscollaboraoffice@gmail.com> Reviewed-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1cdc3df08f80..be8a5be03ed4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -420,6 +420,13 @@ if test -n "$with_android_ndk"; then
# minimum android version that supports aarch64
ANDROID_API_LEVEL=21
ANDROID_APP_ABI=arm64-v8a
+ elif test $host_cpu = x86_64; then
+ android_platform_prefix=x86_64-linux-android
+ android_gnu_prefix=$android_platform_prefix
+ LLVM_TRIPLE=$android_platform_prefix
+ # minimum android version that supports x86_64
+ ANDROID_API_LEVEL=21
+ ANDROID_APP_ABI=x86_64
else
# host_cpu is something like "i386" or "i686" I guess, NDK uses
# "x86" in some contexts
@@ -4315,6 +4322,11 @@ linux-android*)
RTL_ARCH=x86
PLATFORMID=android_x86
;;
+ x86_64)
+ CPUNAME=X86_64
+ RTL_ARCH=X86_64
+ PLATFORMID=android_x86_64
+ ;;
*)
AC_MSG_ERROR([Unsupported host_cpu $host_cpu for host_os $host_os])
;;