summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2018-01-30 18:15:23 +0200
committerAndras Timar <andras.timar@collabora.com>2018-03-25 17:38:30 +0200
commitbf358ba39ed04c535f2e14944618dff27ac366ee (patch)
treec16542d1aaa7ae12f15b686a4ea7173cde6f7254 /configure.ac
parent8847c4efd1338e3a21da455627b2b7ef7d1c265c (diff)
Avoid GPG when --enable-mpl-subset
(cherry picked from commit 8958ed763e91794ed744a75c59461c745a42bc63) Change-Id: I91bf310c77927e24c0693dc5b0b1297f11c001a0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7b35e33f08a2..87b996dbb293 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10121,11 +10121,14 @@ fi
AC_SUBST(ENABLE_PDFIUM)
SYSTEM_GPGMEPP=
-if test "$enable_mpl_subset" = "yes" ; then
- :
-elif test "$_os" = "Linux" -o "$_os" = "Darwin" \
- -o \( "$_os" = "WINNT" -a "$host_cpu" = "x86_64" \) \
- -o \( "$_os" = "WINNT" -a "$host_cpu" = "i686" -a "$WINDOWS_SDK_ARCH" = "x86" \) ; then
+
+if test "$build_for_ios" = "YES"; then
+ AC_MSG_CHECKING([whether gpgmepp should be disabled due to iOS])
+ AC_MSG_RESULT([yes])
+elif test "$enable_mpl_subset" = "yes"; then
+ AC_MSG_CHECKING([whether gpgmepp should be disabled due to building just MPL])
+ AC_MSG_RESULT([yes])
+elif test "$_os" = "Linux" -o "$_os" = "Darwin" -o "$_os" = "WINNT" ; then
dnl ===================================================================
dnl Check for system gpgme
dnl ===================================================================
@@ -10153,6 +10156,8 @@ elif test "$_os" = "Linux" -o "$_os" = "Darwin" \
if test "$_os" != "WINNT"; then
GPG_ERROR_LIBS="-L${WORKDIR}/UnpackedTarball/libgpg-error/src/.libs -lgpg-error"
LIBASSUAN_LIBS="-L${WORKDIR}/UnpackedTarball/libassuan/src/.libs -lassuan"
+ elif test "$host_cpu" = "i686" -a "$WINDOWS_SDK_ARCH" = "x64"; then
+ AC_MSG_ERROR(gpgme cannot be built on cygwin32 for Win64.)
fi
fi
ENABLE_GPGMEPP=TRUE