summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Kaganski <mike.kaganski@collabora.com>2017-12-13 00:04:03 +0300
committerMike Kaganski <mike.kaganski@collabora.com>2018-01-08 18:13:05 +0100
commitca893ce3e4da351576e0d57caada57da190773f2 (patch)
treed5059d606fed561ab696a4b199567fd39b8150dd /configure.ac
parentca9526f42a1eac5aa3ff801e017636ca0e618ebd (diff)
tdf#108580: integrate vc_redist.exe into MSI
... in InstallUISequense. Use --with-vcredist-dir to point to a directory with vc_redist.x64.exe and/or vc_redist.x86.exe. Use --without-vcredist-dir (or --with-vcredist-dir=no) if you don't want to ship it as part of installer and want to silence the configure warning. VCRedist 2015 version 14.0.24215.1 is available at https://www.microsoft.com/en-us/download/details.aspx?id=53840 Since VisualStudio 2015, VC redist merge module that we used before started to work differently: it installs the UCRT only on WinXP, but not on later OSes (Vista to 8.1) which may lack the UCRT (Win10 has it out of the box). The merge module only installs VCRuntime on those systems, which still leaves us with "api-ms-*.dll is missing" problem. (https://blogs.msdn.microsoft.com/vcblog/2015/03/03/introducing-the-universal-crt/ gives more information on VCRedist refactoring background.) Since commit 71d9a61302e65fe091cf70c13fa72b3df09b7e3a, we use a workaround described at the page mentioned above as "App-local deployment of the Universal CRT". We just copy all UCRT DLLs to LibreOffice/program. This has a drawback though, that our UCRT is not updated by Windows Update, so users would rely on LibreOffice updates in case of some vulnerabilities in UCRT (and they could even not realize they have that problem). MS recommends to install UCRT using EXEs they provide from their site. The EXEs install both VCRuntimes and UCRTs, along with required patches, for all Windows versions (Windows XP through Windows 10, where they only install VCRuntimes); the installed libraries are managed by system's update mechanism. But those EXEs cannot be used in MSI custom actions inside InstallExecuteSequence, because they use MSI themselves. So this patch integrates the vc_redist.xXX.exe into MSI binary table, and uses custom action to run the EXE after ExecuteAction in InstallUISequence. This will show the user a VCRedist install window after the main LibreOffice installation finishes; no user interaction is required (except for one additional UAC request), and errors are ignored. Since this installation takes care of both VCRuntime and UCRT, we can ultimately drop both the app-local workaround, and vcredist merge module (so VCRuntime would also be updated by system). The former is done here: this reverts commit 71d9a61302e65fe091cf70c13fa72b3df09b7e3a. This approach has its drawback: if one wants to use unattended installation (without UI; one example is deployment using ActiveDirectory GPO), then InstallUISequence is not run, and so VCRedist isn't installed. In this case, one should install VCRedist separately. Supposedly this should not be huge problem, because this is the case for many existing applications that need separate VCRedist deployment in these scenarios, and unattended installation is advanced stuff that requires prepared user. A notice would be required in release notes and FAQ, though. Change-Id: Ia6a16be60af8a08f41ea7c3dbd457d8f89006006 Reviewed-on: https://gerrit.libreoffice.org/46356 Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com> Tested-by: Mike Kaganski <mike.kaganski@collabora.com> (cherry picked from commit 61b1d631331551b43bc7d619be33bfbfeff7cad6) Reviewed-on: https://gerrit.libreoffice.org/47603 Tested-by: Jenkins <ci@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 15 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 9b3ccf68730d..bbb47e6dcde0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6480,13 +6480,13 @@ fi
AC_SUBST([JITC_PROCESSOR_TYPE])
# Misc Windows Stuff
-AC_ARG_WITH(ucrt-dir,
- AS_HELP_STRING([--with-ucrt-dir],
- [path to the directory with the arch-specific subdirectories of the Windows Universal CRT redistributables
- from the Windows 10 SDK for packaging into the installsets (without those the target system needs to install
+AC_ARG_WITH(vcredist-dir,
+ AS_HELP_STRING([--with-vcredist-dir],
+ [path to the directory with the arch-specific executables (vc_redist.x64.exe, vc_redist.x86.exe)
+ for packaging into the installsets (without those the target system needs to install
the Visual C++ Runtimes manually)]),
,)
-UCRT_REDISTDIR="$with_ucrt_dir"
+VCREDIST_DIR="$with_vcredist_dir"
if test $_os = "WINNT"; then
find_msvc_x64_dlls
find_msms
@@ -6494,27 +6494,20 @@ if test $_os = "WINNT"; then
MSVC_DLLS="$msvcdlls"
MSM_PATH="$msmdir"
SCPDEFS="$SCPDEFS -DWITH_VC${VCVER}_REDIST"
- if test "$UCRT_REDISTDIR" = "no"; then
+ if test "$VCREDIST_DIR" = "no"; then
dnl explicitly disabled
- UCRT_REDISTDIR=""
- else
- UCRT_REDISTDIR="$UCRT_REDISTDIR/$WINDOWS_SDK_ARCH"
- # https://blogs.msdn.microsoft.com/vcblog/2015/03/03/introducing-the-universal-crt/
- # "note that the set of DLLs are necessary is different on different
- # versions of Windows, so you must include all of the DLLs in order for
- # your program to run on all supported versions of Windows"
- if test -f "$UCRT_REDISTDIR/ucrtbase.dll"; then
- cd "$UCRT_REDISTDIR";
- UCRT_DLLS=$(ls *.dll | paste -d " " -s)
- cd -
+ VCREDIST_DIR=""
+ else
+ if test -f "$VCREDIST_DIR/vc_redist.$WINDOWS_SDK_ARCH.exe"; then
+ VCREDIST_EXE="vc_redist.$WINDOWS_SDK_ARCH.exe"
else
- UCRT_REDISTDIR=""
+ VCREDIST_DIR=""
if test -n "$PKGFORMAT"; then
for i in "$PKGFORMAT"; do
case "$i" in
msi)
- AC_MSG_WARN([--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency])
- add_warning "--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency"
+ AC_MSG_WARN([--without-vcredist-dir not specified or exe not found - installer will have runtime dependency])
+ add_warning "--without-vcredist-dir not specified or exe not found - installer will have runtime dependency"
;;
esac
done
@@ -6523,8 +6516,8 @@ if test $_os = "WINNT"; then
fi
fi
-AC_SUBST(UCRT_REDISTDIR)
-AC_SUBST(UCRT_DLLS)
+AC_SUBST(VCREDIST_DIR)
+AC_SUBST(VCREDIST_EXE)
AC_SUBST(MSVC_DLL_PATH)
AC_SUBST(MSVC_DLLS)
AC_SUBST(MSM_PATH)