summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2017-11-23 10:02:13 +0200
committerTor Lillqvist <tml@collabora.com>2017-11-23 10:05:25 +0200
commitb469ba0e7628199d40100d98ff19a835e273db43 (patch)
tree3a993d15cd5b16cab001727113b61b2bbdacee1a /configure.ac
parented885a3cdbfc4b4d194d40508a29334b9780858f (diff)
Don't warn about the installer unless we are building an installer
Change-Id: Iefb40baab9eeaab6923a0f95681466afc6dc6643
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 08a9c9cccf39..d36e75b472b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6500,8 +6500,16 @@ if test $_os = "WINNT"; then
cd -
else
UCRT_REDISTDIR=""
- AC_MSG_WARN([--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency])
- add_warning "--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency"
+ if test -n "$PKGFORMAT"; then
+ for i in "$PKGFORMAT"; do
+ case "$i" in
+ msi)
+ AC_MSG_WARN([--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency])
+ add_warning "--without-ucrt-dir not specified or dlls not found - installer will have runtime dependency"
+ ;;
+ esac
+ done
+ fi
fi
fi
fi